请选择 进入手机版 | 继续访问电脑版

Blog.rosdns.cn 艾丝信息科技

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 2470|回复: 1

MikroTik OS WDS设置使用

[复制链接]
发表于 2016-8-13 23:06:51 | 显示全部楼层 |阅读模式
WDS的主要应用
在不方便拖网线的情况下,扩大无线网络覆盖半径。
建议只扩大一倍,因为每建一次WDS链接,速度会减半。

只有主路由需要开通DHCP和NAT服务,其他均不需要。但必须把Wlan1无线网卡加入桥。
下面是代码供参考。
#===主路由
# aug/13/2016 22:39:04 by RouterOS 6.35.4
# software id = FCPF-C5CD
# wds-main

/interface bridge
add name=bridge1

/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=wlan1

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no frequency=2437 mode=ap-bridge security-profile=default \
    ssid=WDSTEST wds-default-bridge=bridge1 wds-mode=dynamic

/interface ethernet
set [ find default-name=ether1 ] name=www.nowcc.cn
set [ find default-name=ether2 ] name=ether2
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2

/ip pool
add name=lan ranges=192.168.40.10-192.168.40.200

/ip dhcp-server
add add-arp=yes address-pool=lan disabled=no interface=bridge1 lease-time=3d \
    name=landp

/ip address
add address=192.168.40.1/24 interface=bridge1 network=192.168.40.0

/ip dhcp-server network
add address=192.168.40.0/24 dns-server=221.228.255.1 gateway=192.168.40.1

/ip firewall nat
add action=masquerade chain=srcnat

/tool graphing interface
add

#===副路由
# aug/13/2016 22:33:02 by RouterOS 6.35.4
# software id = C0XU-7L0P
# wds2

/system identity
set name="wds2"

/interface bridge
add name=bridge1-wds

/interface bridge port
add bridge=bridge1-wds interface=ether1
add bridge=bridge1-wds interface=wlan1

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no frequency=2437 mode=ap-bridge security-profile=default ssid=\
    WDSTEST wds-default-bridge=bridge1-wds wds-mode=dynamic

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=bridge1-wds


祝你成功!曹帅自编,欢迎大神吐糟。


回复

使用道具 举报

发表于 2016-9-9 20:51:07 | 显示全部楼层
精彩
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|nowcc.cn ( 苏ICP备16033176

GMT+8, 2021-2-27 03:29 , Processed in 0.042806 second(s), 16 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表