请选择 进入手机版 | 继续访问电脑版

Blog.rosdns.cn 艾丝信息科技

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 3546|回复: 1

ROS+三层交换机vlan配置实例

[复制链接]
发表于 2016-7-13 21:37:38 | 显示全部楼层 |阅读模式
ROS+三层交换机vlan配置实例
请看下图:

环境介绍
在这里我 用的是ROS CCR1009 代替原先防火墙,三层交换机神州数码DCN-6804E,需要实现的是,划分多vlan,且VLAN网关设置在三层交换机上,ROS 上只做NAT转发以及回程路由,下面我们根据上图做配置,我们先在ROS上配置好外网(118.114.237.X/24)内网ETH8(10.0.0.1/24)并保证可正常上网,与三层链接的口ETH24配置为Access口,并加入VLAN100,并设置IP(10.0.0.2/24)
1.        ROS配置

2、NAT转换
/ip firewall nat
add action=masquerade chain=srcnat
3、路由配置
/ip route
add check-gateway=ping distance=1 dst-address=192.168.10.0/24 gateway=10.0.0.2
add check-gateway=ping distance=1 dst-address=192.168.20.0/24 gateway=10.0.0.2
add check-gateway=ping distance=1 dst-address=192.168.30.0/24 gateway=10.0.0.2

也可以用一条路由 192.168.0.0/16 10.0.0.2 这样也可以的。
3、DCN-6804 的配置
DCRS-6804E#
DCRS-6804E#sh run
spanning-tree
spanning-tree mode rstp
spanning-tree priority 4096
Interface Ethernet0
vlan 1;10 20 30 100
firewall enable
Interface Ethernet1/1
switchport mode trunk
Interface Ethernet1/2
switchport mode trunk
Interface Ethernet1/3
switchport mode trunk
!
Interface Ethernet1/24
description 接ROSLAN
switchport access vlan 100
Interface Ethernet1/25
interface Vlan10
ip address 192.168.32.1 255.255.255.0
  !forward protocol udp 67(active)!
ip helper-address 10.6.8.254
interface Vlan20
ip address 192.168.20.1 255.255.255.0
interface Vlan30
ip address 192.168.30.1 255.255.255.0
ip route 0.0.0.0/0 10.0.0.1   */配置缺省路由,下一跳到ros的lan口
no login
end
DCRS-6804E#
到这里就配置完成了! 下一步配置增加 bonding 及三层交换机channel 配置
ROS 命令:
/interface bonding
add name=bonding1 slaves=ether7,ether8-lan
add address=10.0.0.1/24 interface=bonding1 network=10.0.0.0
三层交换机增加配置:
port-group 1  /新建一个端口组

port-group 2/新建一个端口组

Interface Ethernet1/0/23   加入端口组 2
switchport access vlan 100  以端口组模式归属vlan100
port-group 2 mode on   
Interface Ethernet1/0/24
switchport access vlan 100
port-group 2 mode on

Interface Port-Channel1 /全局下 将vlan 加入组下 即可

Interface Port-Channel2

在这里就设置好备份端口了。



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

 楼主| 发表于 2016-9-3 16:08:04 | 显示全部楼层
此帖仅作者可见

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|nowcc.cn ( 苏ICP备16033176

GMT+8, 2021-4-18 17:06 , Processed in 0.028032 second(s), 20 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表